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Abstrak 
Di Indonesia, terdapat berbagai macam tumbuhan yang dapat digunakan sebagai obat tradisional, salah satunya 

yaitu daun tanaman kelor (Moringa oleifera L.) yang berpotensi sebagai antidiabetes. Proses penemuan obat 

memerlukan tahapan yang banyak dan waktu yang lama. Salah satu cara dalam mempercepat proses penemuan 

kandidat obat baru adalah dengan pendekatan secara komputasi secara docking molekuler. Bahan yang 

digunakan dalam penelitian adalah protein 2HV5 pada enzim aldosa reduktase, ligan ZST, dan senyawa aktif 

pada daun kelor yaitu marumoside A, quercertin, asam ferulat, kaempferol, dan asam galat. Berdasarkan validasi 

metode docking molekuler, diperoleh nilai RMSD 0,8704 Amstrong, dengan hasil best score docking dari 

masing-masing ligan adalah sebagai berikut: ZST (-126,7120); Pioglitazone (-120,4064); Sitagliptin (-120,056); 

Marumoside A (-93,7856); Quercertin (-80,9221); Asam Ferulat (-80,2762); Kaempferol (-80,0963); dan Asam 

Galat (-72,6102), dimana semua ligan memenuhi aturan Lipinski. Dapat disimpulkan bahwa kelima senyawa 

aktif daun kelor tersebut kurang potensial jika dibandingkan dengan obat pioglitazone dan sitagliptin serta perlu 

dilanjutkan uji aktivitas in vitro di laboratorium. 

Kata Kunci: Antidiabetes, Daun Kelor (Moringa oleifera L.), Aldosa Reduktase, Docking Molekuler 

 

 

Abstract 
In Indonesia, there are various kinds of plants that can be used as traditional medicine, one of which is the leaves 

of the Moringa oleifera L., which have the potential as an antidiabetic. The discovery process requires many 

stages and a long time. One way to start the process of new drug discovery is through a computational approach 

using molecular docking. The material used in this study were protein 2HV5 in aldose reductase enzyme, ZST 

ligand, and active compounds in Moringa leaves, namely marumoside A, quercertin, ferulic acid, kaempferol, 

and gallic acid. Based on the validation of the molecular docking method, an RMSD value of 0.8704 Å was 

obtained, with the results of the best docking scores for each ligand as follows: ZST (-126.7120); Pioglitazine (-

120.4064); Sitagliptin (-120.056); Marumoside A (-93.7856); Quercertin (-80.9221); Ferulic Acid (-80.2762); 

Kaempferol (-80.0963); and Gallic Acid (-72.6102), where all the ligands qualify the Lipinski's rule. It can be 

concluded that the five active compounds of Moringa leaf are less potent when compared to pioglitazone and 

sitagliptin drugs and need to be continued with in vitro activity tests in the laboratory. 

Keywords: antidiabetic, Moringa leaf (Moringa oleifera L.), Aldose Reductase, Molecular Docking 

 

 

 

 

PENDAHULUAN 

 

Diabetes Melitus Tipe 2 adalah penyakit 

gangguan metabolik yang ditandai oleh 

kenaikan kadar gula darah akibat tubuh tidak 

mampu menggunakan insulin secara efektif 

(Saputri et al., 2016; World Health 

Organization, 2021). Organisasi World Health 

Organization (WHO) memprediksi kenaikan 

jumlah pasien DM Tipe 2 di Indonesia dari 8,4 

juta pada tahun    2000 menjadi sekitar 21,3 juta 

pada tahun 2030. Begitu pula dengan 

International Diabetes Federation (IDF) yang 

memperkirakan kenaikan jumlah pasien DM 
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dari 10,7 juta menjadi 13,7 juta pada tahun 

2030 (Perkeni, 2021). Hasil Riset Kesehatan 

Dasar (Riskesdas) 2018 juga menunjukkan 

bahwa prevalensi DM di Indonesia 

berdasarkan diagnosis dokter pada umur ≥ 15 

tahun meningkat dari 1,5%   (2013) menjadi 

2%, serta prevalensi DM menurut hasil 

pemeriksaan gula darah meningkat dari 6,9% 

(2013) menjadi 8,5% (Kemenkes RI, 2020). 

Pengobatan DM Tipe 2 dapat 

menggunakan obat-obatan penghambat enzim 

aldosa reduktase. Struktur kristal protein 

dengan kode PDB 2HV5 merupakan suatu 

aldosa reduktase. Enzim aldosa reduktase 

adalah enzim yang terdapat di beberapa 

bagian tubuh dan berfungsi dalam 

metabolisme glukosa jalur poliol yang 

bertanggung jawab dalam pembentukan 

fruktosa dan glukosa. Peningkatan aktivitas 

aldosa reduktase dapat memicu peningkatan 

konsentrasi gula darah pada pasien diabetes 

sehingga insulin menjadi tidak sensitif 

(Saputri et al., 2016). Obat yang digunakan 

sebagai pembanding dalam penelitian ini 

adalah pioglitazone dan sitagliptin. 

Selain obat sintetik, tumbuhan telah 

menjadi sumber utama obat-obatan pada 

bidang kesehatan karena adanya efek samping 

penggunaan obat kimia sintetik (Manalu et al., 

2021). Penggunaan bahan alam, baik sebagai 

obat maupun tujuan lain cenderung meningkat 

terlebih dengan adanya isu back to nature. 

Obat tradisional dari bahan alam menjadi 

salah satu alternatif pengobatan seperti 

diabetes melitus (Simanjuntak, 2018), salah 

satunya adalah daun kelor. Tanaman kelor 

(Moringa oleifera L.)  termasuk ke dalam 

kategori tanaman obat yang telah dievaluasi 

potensinya sebagai agen terapeutik untuk 

diabetes. Daun kelor merupakan salah satu 

tanaman obat tradisional yang berkhasiat 

sebagai obat antidiabetik dan antiinflamasi 

(Yasaroh et al., 2021). Daun kelor 

mengandung beberapa senyawa bioaktif yang 

telah berhasil diidentifikasi. Senyawa-

senyawa ini dikelompokkan sebagai vitamin, 

karotenoid, polifenol, asam fenolik, 

flavonoid, alkaloid, glukosinolat, isotiosianat, 

tanin, saponin, oksalat, dan fitat (Leone et al., 

2015). Berdasarkan hasil uji fitokimia, daun 

kelor menunjukkan adanya senyawa alkoloid 

dan steroid/triterpenoid yang berperan aktif 

dalam menurunkan kadar gula darah (Azizah 

et al., 2018). 

Berdasarkan latar belakang ini, penulis 

tertarik dengan melakukan penelitian senyawa 

aktif pada daun kelor sebagai antidiabetes 

terhadap hubungannya dengan enzim aldosa 

reduktase yang mencerna karbohidrat. 

 

METODE 

 

Pada penelitian ini dilakukan docking 

menggunakan protein Human Aldose 

Reductase dengan kode 2HV5. Senyawa uji 

yang diteliti yaitu senyawa uji dari tanaman 

daun kelor (Moringa oleifera L.) dengan obat 

pembanding pioglitazone dan sitagliptin. 

Molekuler docking bertujuan untuk 

memprediksi kompleks antara ligan dengan 

reseptor dan hasil akhirnya yaitu score 

docking. Hasil score docking antara senyawa 

aktif daun kelor dengan protein dibandingkan 

dengan obat pioglitazone dan sitagliptin. Jika 

senyawa aktif daun kelor memiliki score 

docking lebih rendah dibandingkan dengan 

ligan pembanding maka senyawa aktif 

tersebut memiliki kemampuan yang lebih baik 

sebagai antidiabetes. 

 

Alat dan bahan 

Penelitian ini berdasarkan metode 

computer-aided drug design dengan bantuan 

perangkat keras: Laptop dengan spesifikasi 

prosesor Intel Celeron N3060 dual-core 

1,6GHz TurboBoost 2,48GHz, RAM 2 GB, 

DDR3L, Windows 10 64-bit sebagai sistem 

operasi. Perangkat lunak yang digunakan 

adalah YASARA, MarvinSketch, PLANTS, 

PDB (Protein Data Bank), Pubchem 

(database senyawa), Lipinski’s Rule of Five 

(http://www.scfbioiitd.res.in/software/drugde

sign/lipinski.jsp), dan Discovery Studio 

Biovia. Bahan yang digunakan adalah protein 

Human Aldose Reductase yang 

dikomplekskan dengan inhibitor zopolrestat 

setelah tiga hari perendaman. Protein ini 

diunduh dari PDB dengan kode: 2HV5. Ligan 

asli yang digunakan adalah ligan ZST dengan 

nama 3,4–dihydro -4-oxo-3-((5-trifluoro 

http://www.scfbio-iitd.res.in/software/drugdesign/lipinski.jsp
http://www.scfbio-iitd.res.in/software/drugdesign/lipinski.jsp
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methyl 2 = benzo thiazolyl) methyl)-1-

phthalazine acetic acid, senyawa pembanding 

antidiabetes: pioglitazone dan sitagliptin, 

serta senyawa uji dari beberapa senyawa aktif 

daun kelor (Moringa oleifera L.) yaitu asam 

galat, asam ferulat, quercetin, kaempferol, dan 

marumoside A.  

 

PROSEDUR KERJA 

 

Preparasi Protein Uji dan Ligan Asli 

Protein target uji yang digunakan adalah 

reseptor aldosa reduktase dengan kode PDB: 

2HV5 dalam format .pdb yang terlebih dahulu 

diunduh melalui website PDB 

(https://www.rcsb.org/strukture/2hv5). 

Protein target dilakukan pemisahan dari 

berbagai residu, ligan atau pelarut 

menggunakan perangkat lunak YASARA 

(Edit>Delete>Residue) serta dilakukan 

penghapusan molekul air (Edit>Delete> 

Waters). Selanjutnya, dilakukan penambahan 

hidrogen (Edit>Add>Hydrogen to all) yang 

bertujuan untuk optimasi nilai docking yang 

dihasilkan setelah selesai preparasi, protein 

disimpan dalam format mol.2 dengan nama 

“protein.mol2”. 

Preparasi ligan asli dari protein 

menggunakan perangkat lunak YASARA. 

Ligan asli yang digunakan adalah ligan ZST. 

Ligan asli dipisahkan dari protein dan residu 

seperti air. Pemisahan ligan dari protein 

dilakukan dengan Edit>Delete>Protein. 

Langkah pemisahan air yaitu 

Edit>Delete>Waters, kemudian protein 

ditambahkan hidrogen dengan langkah 

Edit>Add>Hydrogen to all. Setelah selesai 

ligan disimpan dalam format mol.2 dengan 

nama “ref_ligand.mol2”. 

 

Preparasi Ligan  

Preparasi ligan menggunakan aplikasi 

MarvinSketch. Berkas ligan asli yang 

dipreparasi merupakan ligan asli yang 

sebelumnya telah dibuat pada YASARA. 

Kemudian proses preparasi dilanjutkan 

dengan mengubah struktur ligan dalam bentuk 

2D dengan langkah Structure>Clean 

2D>Clean in 2D. Kemudian ligan 

dikondisikan pada pH 7,4 dengan cara 

diprotonasi, proses ini bertujuan untuk  

menyesuaikan pH cairan tubuh manusia 

dengan  langkah Tools>protonations>Major 

Microspecies, setelah diperoleh hasilnya,  

berkas disimpan dengan nama “Ligand2D” 

dalam format mrv., selanjutnya berkas ligan 

Ligan2D.mrv dikonformasi dengan langkah 

Tools>comformation>Confomer. Setelah 

diperoleh konfomernya, berkas disimpan 

dengan nama “ligand” dalam format .mol2. 

Pada ligan senyawa uji, berkas yang akan 

dipreparasi adalah struktur yang diperoleh 

dari Pubchem (database senyawa) kemudian 

dilakukan langkah yang sama seperti 

preparasi ligan asli (Rosario et al., 2021). 

 

Validasi Metode Molecular Docking 

Validasi metode perlu dilakukan 

sebelum dilakukan docking antara ligan uji 

dengan protein. Validasi ditentukan 

berdasarkan nilai RMSD (Root Mean 

Square Deviation) menggunakan perangkat 

lunak YASARA (Analyze>RSMD 

of>Molecules) dengan memasukkan ligan 

asli dan reseptor dalam format .mol2. 

Validasi yang diterima adalah nilai 

RSMD kurang dari 2,00 Amstrong, jika 

nilai RSMD lebih dari 2,00 Amstrong 

dianggap tidak valid karena jarak ikatannya 

akan tidak optimal. 

 

Proses Molecular Docking dengan 

PLANTS 1.1  

Proses docking pada penelitian ini 

dilakukan menggunakan sistem operasi 

Windows. Protein dan ligan dari hasil 

preparasi memiliki format .mol2. Kemudian 

untuk memperoleh sisi pengikatan dilakukan 

dengan perintah “plants --mode bind 

ref_ligand.mol2 5 protein.mol2”. Proses 

docking dijalankan dengan perintah “plants –

mode screen pc_2hv5.txt” pada program 

PLANTS. Untuk melihat data hasil docking 

dijalankan dengan perintah “cd results” dan 

“more bestranking.csv” pada terminal 

program docking.  

Dalam penelitian ini, ada beberapa ligan 

yang digunakan yaitu ligan asli, ligan 

pembanding dari obat antidiabetes, dan ligan 

uji yang diperoleh dari senyawa aktif daun 

https://www.rcsb.org/strukture/2hv5
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kelor (Moringa oleifera L.) terdiri dari: asam 

galat, asam ferulat, quercetin, kaempferol, dan 

marumoside A. 

Senyawa aktif yang dijadikan ligan uji 

memiliki sifat kemiripan obat yang sesuai 

dengan atutan Lipinski, melalui website 

http://www.scfbioiitd.res.in/software/drugdes

ign/lipinski.jsp.  

 

Visualisasi Hasil Docking 

Hasil docking divisualisasikan dengan 

menggunakan perangkat lunak Discovery 

Studio Biovia. Berkas interaksi antara protein 

dengan ligan terlebih dahulu digabungkan di 

perangkat lunak YASARA dengan langkah 

Edit>Join>Object dan disimpan dalam 

format .pdb kemudian dilakukan visualisasi 

pada Discovery Studio Biovia untuk melihat 

struktur dua dimensinya. 

 

HASIL DAN PEMBAHASAN 

 

Validasi Metode Docking  

Target protein yang digunakan dalam 

penelitian ini adalah protein aldosa reduktase 

yang terdapat pada PDB 2HV5. Pemilihan 

protein 2HV5 berdasarkan pada nilai 

resolusinya yang rendah yaitu 1,59 Amstrong. 

Protein reseptor dengan nilai resolusi yang 

rendah menandakan bahwa protein tersebut 

memiliki stabilitas model yang baik dalam 

proses docking (Rachmania et al., 2018). 

Dapat dilihat pada Gambar 1. 

 
Gambar 1. Struktur reseptor protein 

aldosa reduktase (2HV5) 

 

Struktur ligan baik ligan asli, ligan 

pembanding, dan ligan senyawa aktif 

dikondisikan pada pH 7,4 untuk 

menyesuaikan pH tubuh manusia karena 

proses docking memiliki kemampuan dalam 

mengikuti reaksi yang terjadi dalam tubuh 

manusia dan hasil docking yang diperoleh 

akan optimal (Agistia et al., 2013). Struktur 

ligan dioptimasi dengan dilakukan 

konformasi di perangkat lunak MarvinSketch 

menjadi 20 konformer sehingga diperoleh 20 

bentuk struktur 3D dengan bentuk yang 

berbeda dan memiliki energi bebas yang 

optimal (Rachmania et al., 2018). Hal ini 

terjadi karena adanya perubahan rotasi atom 

pada masing-masing konformasi secara acak 

sehingga konformasi yang dihasilkan 

memiliki jumlah energi terbaik dan bentuk 

ligan yang optimal (Primana & Widada, 

2015). 

Pada validasi docking, nilai RMSD (Root 

Mean Squared Deviation) <2 Amstrong 

menunjukkan parameter metode molecular 

docking yang digunakan memberikan hasil 

yang lebih mendekati hasil eksperimental 

(Nursamsiar et al., 2020). Setelah dilakukan 

validasi diperoleh nilai RMSD dari protein 

2HV5 yaitu 0,8074 Amstrong sehingga 

diketahui bahwa metode docking pada 

penelitian ini dianggap valid dan dapat 

dilanjutkan uji docking dengan ligan uji dari 

senyawa aktif daun kelor. Visualisasi 

redocking dapat dilihat pada Gambar 2. Nilai 

RMSD yang mendekati nol menunjukkan 

bahwa pose antara ligan asli dengan ligan 

copy memiliki kemiripan. Hal ini 

menunjukkan metode yang digunakan pada 

penelitian ini dapat diterima dan dilanjutkan 

untuk skrining virtual sebagai upaya dalam 

menemukan kandidat obat baru (Rachmania 

et al., 2018).  

 

 
Gambar 2. Validasi docking ligan asli 

dengan nilai RMSD 0,8704 Å 

http://www.scfbio/
http://www.scfbio-iitd.res.in/software/drugdesign/lipinski.jsp
http://www.scfbio-iitd.res.in/software/drugdesign/lipinski.jsp
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Analisa Skor Docking Senyawa Uji dan 

Senyawa Pembanding 

Dari hasil docking yang memprediksi 

senyawa marumoside A, quercetin, asam 

ferulat, kaempferol, dan asam galat dengan 

protein 2HV5. Diperoleh hasil bahwa 

senyawa-senyawa tersebut memiliki nilai skor 

docking yang lebih tinggi dibandingkan 

dengan ligan aslinya, sehingga dapat 

diketahui ikatan antara kompleks protein-

ligan asli lebih kuat (stabil) dibandingkan 

dengan ikatan protein-senyawa aktif daun 

kelor (Moringa oleifera L.). 

Skor docking senyawa aktif juga 

memiliki nilai yang lebih tinggi dibandingkan 

dengan skor senyawa pembanding 

(pioglitazone dan sitagliptin) sehingga dapat 

disimpulkan bahwa senyawa aktif daun kelor 

sebagai inhibitor enzim aldosa reduktase 

kurang potensial jika dibandingkan dengan 

dua senyawa pembanding. Dapat dilihat pada 

Tabel 1. 

 

Tabel 1. Hasil docking antara ligan 

pembanding dan ligan senyawa aktif  daun 

kelor (Moringa oleifera L.) dengan ligan 

ZST 

 

Untuk melihat sifat fisikokimia ligan 

pada saat melintasi membran sel dalam tubuh, 

dilakukan uji Lipinski. Suatu ligan harus 

memenuhi syarat berdasarkan aturan Lipinski, 

yaitu nilai LogP ≤5, berat molekul ≤500 

Dalton, ikatan hidrogen akseptor ≤10, ikatan 

hidrogen donor ≤5, dan refraksi molar antara 

40-130. Ligan yang memiliki berat molekul 

≤500 Dalton memiliki kemampuan yang lebih 

baik dalam menembus membran sel. 

Kemampuan suatu senyawa dalam menembus 

lapisan lipid bilayer dapat dipengaruhi oleh 

nilai LogP. Senyawa dengan nilai LogP lebih 

dari 5 akan memiliki kemampuan yang baik 

saat menembus lapisan lipid bilayer membran 

sel serta terdistribusi secara luas di dalam 

tubuh sehingga terjadi pengurangan 

sensitivitas ikatan ligan-protein yang 

berakibat pada peningkatan toksisitas ligan 

dalam tubuh. Ligan dengan nilai LogP yang 

kecil memiliki kecenderungan untuk bersifat 

hidrofobik dan larut dalam air.  (Adriani, 

2018). Berdasarkan hasil Lipinski, diketahui 

bahwa kelima senyawa aktif yang terdapat 

pada daun kelor (Moringa oleifera L.) 

memenuhi aturan Lipinski. Dapat dilihat pada 

Tabel 2. 

 

Tabel 2. Hasil skrining Lipinski senyawa 

aktif daun kelor (Moringa oleifera L.) 

Ligan BM IHD IHA LogP RM 

Marumoside A 297 4 6 -1,08 121,4 

Quercetin 302 5 7 1,99 122,1 

Asam Ferulat 194 2 3 1,50 81,0 

Kaempferol 286 4 6 2,28 117,3 

Asam Galat 170 4 4 0,50 67,1 

Keterangan: BM (Berat Molekul), IHD (Ikatan 

Hidrogen Donor), IHA (Ikatan Hidrogen Akseptor), 

RM (Refraksi Molar). 

 

Visualisasi Hasil Docking 

Hasil molecular docking dari ligan 

divisualisasikan dengan aplikasi Discovery 

Studio Biovia. Visualisasi dilakukan dengan 

tujuan untuk mengetahui interaksi yang 

terjadi antara ligan dengan  protein 2HV5.  

No. Ligan Skor docking 

1. ZST -126,7120 

2. Pioglitazone -120,4064 

3. Sitagliptin -120,0560 

4. Marumoside A -93,7856 

5. Quercetin -80,9221 

6. Asam ferulat -80,2762 

7. Kaempferol -80,0963 

8. Asam galat -72,6102 
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Gambar 3. Visualisasi docking ligan asli 

ZST dengan protein 2HV5 

 

Berdasarkan hasil simulasi penambatan 

molekul (molecular docking), dapat 

disimpulkan bahwa beberapa senyawa aktif 

daun kelor memiliki ikatan yang stabil karena 

hasil energi afinitas ikatan (skor docking) 

memiliki nilai negatif. Semakin negatif 

skornya maka semakin stabil ikatannya. 

Senyawa pioglitazone memiliki skor terendah 

dalam docking, dimana senyawa ini telah 

dijadikan sebagai salah satu obat diabetes 

yang beredar, dengan senyawa tertingginya 

adalah asam galat. 

 

KESIMPULAN 

 

Senyawa yang terdapat pada daun kelor 

(Moringa oleifera L.) memiliki potensi 

sebagai antidiabetes. Berdasarkan metode 

molekuler docking terhadap protein 2HV5 

yang merupakan aldosa reduktase, lima 

senyawa yang terdapat pada daun kelor dapat 

menghambat protein 2HV5, namun kurang 

potensial jika dibandingkan dengan obat 

pioglitazone dan sitagliptin. 
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